B RStudio IDE Commands

The following table enumerates all of the commands currently supported by RStudio. These command IDs can be used in RStudio API calls such as rstudioapi::executeCommand.

Id Description
activateBuild Show Build
activateConnections Show Connections
activateConsole Move Focus to Console
activateConsolePane Move Focus to Console
activateData Show Data
activateEnvironment Show Environment
activateFiles Show Files
activateHelp Move Focus to Help
activateHistory Show History
activateJobs Show Jobs
activateLauncherJobs Show Launcher
activatePackages Show Packages
activatePlots Show Plots
activatePresentation Show Presentation
activateSource Move Focus to Source
activateTerminal Move Focus to Terminal
activateVcs Show Vcs
activateViewer Show Viewer
addCursorAbove Add Cursor Above Current Cursor
addCursorBelow Add Cursor Below Current Cursor
authoringRPresentationsHelp Guide to using R Markdown
browseAddins Browse addins
browseCheatSheets Browse available cheatsheets in your web browser
buildAll Install the package and restart R
buildBinaryPackage Build a binary package
buildSourcePackage Build a source package
buildToolsProjectSetup Configure build tools
checkForUpdates Check for Updates
checkPackage R CMD check
checkSpelling Check spelling in document
cleanAll Clean all
clearHelpHistory Clear history
clearHistory Clear all history entries
clearJobs Clean up all completed local jobs
clearKnitrCache Clear the knitr cache for the current document
clearPlots Clear all Plots
clearPrerenderedOutput Clear the prerendered output for the current document
clearPresentationCache Clear knitr cache for this presentation
clearRecentFiles Clear List
clearRecentProjects Clear Project List
clearTerminalScrollbackBuffer Clear terminal
clearUserPrefs Clear User Prefs
clearWorkspace Clear objects from the workspace
closeAllSourceDocs Close All
closeOtherSourceDocs Close All Except Current
closeProject Close the currently open project
closeSourceDoc Close
closeTerminal Close current terminal session
codeCompletion Show code completions at the current cursor location
commentUncomment Comment or uncomment the current line/selection
compileNotebook Compile a report from the current R script
compilePDF Compile a PDF from the current LaTeX or Sweave document
consoleClear Clear console
copyDummy Copy
copyFile Copy selected file or folder
copyFileTo Copy selected file or folder to another folder
copyLinesDown Copy Lines Down
copyPlotToClipboard Copy the current plot to the clipboard
cutDummy Cut
debugBreakpoint Set or remove a breakpoint on the current line of code
debugClearBreakpoints Remove all the breakpoints in the current project
debugContinue Continue execution until the next breakpoint is encountered
debugDumpContents Dump Editor Contents…
debugFinish Execute the remainder of the current function or loop
debugHelp Guide to debugging features
debugImportDump Import Editor Contents…
debugStep Execute the next line of code
debugStepInto Step into the current function call
debugStop Exit debug mode
deleteFiles Delete selected files or folders
devtoolsLoadAll Execute devtools::load_all
diagnosticsReport Write Diagnostics Report
disconnectConnection Disconnect from a connection
editLinesFromStart Create a new cursor at start of each line in selection
editRmdFormatOptions Edit the R Markdown format options for the current file
editUserPrefs Edit User Prefs File
errorsBreak Break when any unhandled error occurs
errorsMessage Print the error message when an unhandled error occurs
errorsTraceback Show the error inspector when an unhandled error occurs
executeAllCode Run all of the code in the source file
executeCode Run the current line or selection
executeCodeWithoutMovingCursor Run the current line or selection without moving the cursor
executeCurrentChunk Run the current code chunk
executeCurrentFunction Run the top-level function definition, if any, that contains the cursor
executeCurrentLine Execute the line which contains the cursor
executeCurrentParagraph Execute the current paragraph of code, delimited by blank lines.
executeCurrentSection Run the code section that contains the cursor
executeCurrentStatement Execute the entire R statement which contains the cursor.
executeFromCurrentLine Run from the current line through the end of the source file
executeLastCode Re-run the previous code region
executeNextChunk Run the next code chunk
executePreviousChunks Run all above the current one
executeSetupChunk Run the initial setup chunk
executeSubsequentChunks Run all chunks after the current one
executeToCurrentLine Run from the beginning of the source file up through the current line
expandSelection Expand selection
expandToLine Expand Selection to Line
expandToMatching Expand selection to matching bracket
exportFiles Export selected files or folders
extractFunction Turn the current selection into a function
extractLocalVariable Extract a variable out of the current selection
findFromSelection Use Selection for Find
findInFiles Find in Files…
findNext Find next occurrence
findPrevious Find previous occurrence
findReplace Find…
findSelectAll Find and select all matches
findUsages Find source locations where this symbol is used
firstTab First Tab
fold Collapse
foldAll Collapse All
forceQuitSession Quit the current R session even if busy
goToDefinition Go to to the definition of the currently selected function
goToFileFunction Go To File/Function…
goToHelp Go to help for the currently selected function
goToLine Go to Line…
goToNextChunk Go to next chunk
goToNextSection Go to next section/chunk
goToPrevChunk Go to previous chunk
goToPrevSection Go to previous section/chunk
gotoProfileSource Open sources associated with the selection
goToWorkingDir View the current working directory
helpBack Previous topic
helpForward Next topic
helpHome Show R Help
helpKeyboardShortcuts Keyboard Shortcuts Help
helpPopout Show in new window
helpUsingRStudio RStudio Docs
hideToolbar Hide Toolbar
historyRemoveEntries Remove the selected history entries
historySendToConsole Send the selected commands to the R console (Enter)
historySendToSource Insert the selected commands into the current document (Shift+Enter)
importDatasetFromCsv From CSV
importDatasetFromCsvUsingBase From Text (base)…
importDatasetFromCsvUsingReadr From Text (readr)…
importDatasetFromFile From Local File…
importDatasetFromJDBC From JDBC…
importDatasetFromJSON From JSON…
importDatasetFromMongo From Mongo DB…
importDatasetFromODBC From ODBC…
importDatasetFromSAS From SAS…
importDatasetFromSAV From SAV…
importDatasetFromSAV From SPSS…
importDatasetFromStata From Stata…
importDatasetFromURL From Web URL…
importDatasetFromXLS From Excel…
importDatasetFromXML From XML…
insertChunk Insert a new code chunk
insertChunkBash Insert a new Bash chunk
insertChunkD3 Insert a new D3 chunk
insertChunkPython Insert a new Python chunk
insertChunkR Insert a new R chunk
insertChunkRCPP Insert a new Rcpp chunk
insertChunkSQL Insert a new SQL chunk
insertChunkStan Insert a new Stan chunk
insertRoxygenSkeleton Insert a roxygen comment for the current function
insertSection Insert a new code section
insertSnippet Expand snippet at cursor
installPackage Install R packages
interruptR Interrupt R
interruptTerminal Send Ctrl+C to Current Terminal
joinLines Join Lines
jumpTo Jump To…
jumpToMatching Jump to matching bracket
knitDocument Knit the current document
knitWithParameters Knit the document with a set of custom parameters
lastTab Last Tab
layoutConsoleOnLeft Console on Left
layoutConsoleOnRight Console on Right
layoutEndZoom Show All Panes
layoutZoomBuild Zoom Build
layoutZoomConnections Zoom Connections
layoutZoomConsole Zoom Console
layoutZoomConsolePane Zoom Console Pane
layoutZoomEnvironment Zoom Environment
layoutZoomFiles Zoom Files
layoutZoomHelp Zoom Help
layoutZoomHistory Zoom History
layoutZoomPackages Zoom Packages
layoutZoomPlots Zoom Plots
layoutZoomSource Zoom Source
layoutZoomVcs Zoom VCS
layoutZoomViewer Zoom Viewer
loadHistory Load history from an existing file
loadWorkspace Load workspace
logFocusedElement Log focused element
macPreferences Preferences…
markdownHelp Markdown quick reference
maximizeConsole Maximize Console
modifyKeyboardShortcuts Modify keyboard shortcuts
moveFiles Move selected files or folders
moveLinesDown Move Lines Down
moveLinesUp Move Lines Up
moveTabLeft Move Tab Left
moveTabRight Move Tab Right
moveTabToFirst Move Tab to First
moveTabToLast Move Tab to Last
newConnection Create a new connection
newCppDoc Create a new C++ file
newD3Doc Create a new D3 script
newFolder Create a new folder
newProject Create a project
newPythonDoc Create a new Python script
newRDocumentationDoc Create a new Rd documentation file
newRHTMLDoc Create a new R HTML document
newRMarkdownDoc Create a new R Markdown document
newRNotebook Create a new R Markdown notebook
newRPlumberDoc Create a new Plumber API
newRPresentationDoc Create a new R presentation
newRShinyApp Create a new Shiny web application
newSession Open a new R session
newSourceDoc Create a new R script
newSqlDoc Create a new SQL script
newStanDoc Create a new Stan program
newSweaveDoc Create a new R Sweave document
newTerminal Create a new terminal
newTextDoc Create a new text file
nextPlot Next plot
nextTab Next Tab
nextTerminal Show next terminal
notebookClearAllOutput Remove all code chunk output in the current file
notebookClearOutput Clear the output of the current notebook chunk
notebookCollapseAllOutput Collapse all code chunk output in the current file
notebookExpandAllOutput Expand all code chunk output in the current file
notebookToggleExpansion Expand or collapse the output of the current notebook chunk
openDataImportCheatSheet Import data with readr
openDataTransformationCheatSheet Data transformation with dplyr
openDataVisualizationCheatSheet Data visualization with ggplot2
openDataWranglingCheatSheet Data manipulation with dplyr and tidyr
openDeveloperConsole Open Developer Console
openHtmlExternal View the page with the system web browser
openPackageDevelopmentCheatSheet Package development with devtools
openProfile Opens a profile from a file
openProfileInBrowser Opens current profile in a web browser
openProject Open a project
openProjectInNewWindow Open project in a new R session
openPurrrCheatSheet List manipulation with purrr
openRMarkdownCheatSheet R Markdown cheat sheet
openRMarkdownReferenceGuide R Markdown reference guide
openRoxygenQuickReference Roxygen quick reference
openRStudioIDECheatSheet RStudio IDE cheat sheet
openSharedProject Open a project shared with you
openShinyCheatSheet Build web applications with Shiny
openSourceDoc Open an existing file
openSparklyrCheatSheet Interfacing Apache Spark with sparklyr
packratBootstrap Use packrat with this project
packratBundle Bundle a Packrat Project
packratCheckStatus Check the status of the Packrat library
packratClean Remove unused packages from your packrat library
packratHelp Help on using packrat with R projects
packratOptions Configure packrat options for this project
paneLayout Pane Layout…
pasteDummy Paste
plumberRunInBrowser Run the Plumber API in the system’s default Web browser
plumberRunInPane Run the Plumber API in an RStudio pane
plumberRunInViewer Run the Plumber API in an RStudio viewer window
popoutDoc Show in new window
presentationEdit Edit this slide of the presentation
presentationFullscreen Show presentation in full screen mode
presentationHome Go to the first slide
presentationNext Go to the next slide
presentationPrev Go to the previous slide
presentationSaveAsStandalone Save the presentation as a standalone web page
presentationViewInBrowser View the presentation in an external web browser
previewHTML Show a preview of the current document as HTML
previewJS Preview the active JavaScript document
previewSql Preview the active SQL document
previousPlot Previous plot
previousTab Previous Tab
previousTerminal Show previous terminal
printCppCompletions Print C++ Completions
printHelp Print topic
printSourceDoc Print the current file
profileCode Profile the current line or selection
profileHelp Guide to profiling features
projectOptions Edit options for the current project
publishHTML Publish the current document
quickAddNext Find and add next occurence
quitSession Quit the current R session
raiseException Raise Exception
raiseException2 Raise Exception JS
rcppHelp Help on using Rcpp
rebuildAll Clean previous output and rebuild all
redoDummy Redo
reflowComment Reflow selected comment lines so they wrap evenly
reformatCode Reformat the current line/selection
refreshConnection Refresh data
refreshEnvironment Refresh the list of objects in the environment
refreshFiles Refresh file listing
refreshHelp Refresh topic
refreshHtmlPreview Refresh the preview
refreshPackages Refresh Package listing
refreshPlot Refresh current plot
refreshPresentation Refresh the presentation
refreshWorkspace Refresh Workspace
reindent Reindent the current line/selection
reloadPlumberAPI Reload the Plumber API
reloadShinyApp Reload the Shiny application
reloadUi Reload UI
removeConnection Remove connection from the connection history
removeLine Remove Line
removePlot Remove the current plot
renameFile Rename selected file or folder
renameInScope Rename symbol in current scope
renameSourceDoc Rename current document
renameTerminal Change terminal session name
renvHelp Learn how to use renv
renvRestore Restore your project library from renv.lock
renvSnapshot Snapshot the state of your project library
reopenSourceDocWithEncoding Reopen the current file with a different encoding
replaceAndFind Replace and find next occurrence
restartR Restart R
restartRClearOutput Restart R session and clear chunk output
restartRRunAllChunks Restart R session and run all chunks
returnDocToMain Return to main window
roxygenizePackage Build package documentation
rsconnectConfigure Configure the application
rsconnectDeploy Publish the application or document
rsconnectManageAccounts Connect or disconnect accounts
rstudioAgreement RStudio Agreement
rstudioCommunityForum RStudio Community Forum
rstudioLicense RStudio License
rstudioSupport RStudio Support
runSelectionAsJob Run the selected code as a local job
runSelectionAsLauncherJob Run the selected code as a launcher job
saveAllSourceDocs Save all open documents
saveHistory Save history into a file
saveHtmlPreviewAs Save the page to another location
saveHtmlPreviewAsLocalFile Download the page to a local file
savePlotAsImage Save the current plot as an image file
savePlotAsPdf Save the current plot as a PDF file
saveProfileAs Saves current profile into a file
saveSourceDoc Save current document
saveSourceDocAs Save current file to a specific path
saveSourceDocWithEncoding Save the current file with a different encoding
saveWorkspace Save workspace as
searchHistory Search history for commands matching a pattern
sendTerminalToEditor Copy current terminal’s buffer to a new editor buffer
sendToTerminal Send the current line or selection to terminal
setWorkingDir Select and change to a new working directory
setWorkingDirToActiveDoc Change working directory to path of active document
setWorkingDirToFilesPane Change working directory to location of Files pane
setWorkingDirToProjectDir Change working directory to project root directory
shareProject Share this project with others
shinyCompareTest Compare test results for Shiny application
shinyRecordTest Record test for Shiny application
shinyRunAllTests Run tests for Shiny application
shinyRunInBrowser Run the Shiny application in the system’s default Web browser
shinyRunInPane Run the Shiny application in an RStudio pane
shinyRunInViewer Run the Shiny application in an RStudio viewer window
showAboutDialog About RStudio
showAccessibilityOptions Accessibility Options…
showBuildMenu Show Build Menu
showCodeMenu Show Code Menu
showDebugMenu Show Debug Menu
showDiagnosticsActiveDocument Show diagnostics for the active document
showDiagnosticsProject Show diagnostics for all source files in the current project
showEditMenu Show Edit Menu
showFileMenu Show File Menu
showGpuDiagnostics Show GPU Diagnostics
showHelpMenu Show Help Menu
showHtmlPreviewLog Show the compilation log for this document
showLicenseDialog Manage License
showLogFiles Show Log Files
showManipulator Show the manipulator for this plot
showOptions Global Options…
showPdfExternal Show in an external PDF viewer window
showPlotsMenu Show Plots Menu
showProfileMenu Show Profile Menu
showRequestLog Request Log
showSessionMenu Show Session Menu
showSessionServerOptionsDialog Configure available session servers
showShellDialog Execute shell commands
showTerminalInfo Show info on current terminal
showToolbar Show Toolbar
showToolsMenu Show Tools Menu
showViewMenu Show View Menu
showWarningBar Show warning bar
shrinkSelection Shrink selection
sortLauncherJobsRecorded Sort jobs by time submitted
sortLauncherJobsState Sort jobs by current state
sourceActiveDocument Source the contents of the active document
sourceActiveDocumentWithEcho Source the contents of the active document (with echo)
sourceAsJob Run the current R script as a local job
sourceAsLauncherJob Run the current R script on a cluster
sourceFile Source the contents of an R file
sourceNavigateBack Go back to the previous source location
sourceNavigateForward Go forward to the next source location
sparkHelp Help on using Spark with RStudio
sparkLog View the log for the Spark connection
sparkUI View the browser UI for the Spark connection
splitIntoLines Create a new cursor on each line in current selection
startJob Run a background local job
startLauncherJob Run a background job on a cluster
startProfiler Start profiling R code
stopBuild Stop the current build
stopProfiler Stop profiling R code
suspendSession Suspend R Session
switchToChunkBash Switch chunk to Bash
switchToChunkPython Switch chunk to Python
switchToChunkR Switch chunk to R
switchToChunkRCPP Switch chunk to Rcpp
switchToChunkSQL Switch chunk to SQL
switchToChunkStan Switch chunk to Stan
switchToTab Switch to Tab…
synctexSearch Sync PDF view to editor location (Ctrl+Click)
terminateR Forcibly terminate R session
testPackage Run tests for package
testShinytestFile Run test using the shinytest package
testTestthatFile Run tests using the testthat package
toggleDocumentOutline Show document outline
toggleEditorTokenInfo Toggle Editor Token Information
toggleFullScreen Toggle Full Screen
toggleScreenReaderSupport Screen Reader Support
toggleToolbar Toggle Toolbar
undoDummy Undo
unfold Expand
unfoldAll Expand All
updateCredentials Update Credentials
updatePackages Check for package updates
uploadFile Upload files to server
usingRMarkdownHelp Guide to using R Markdown
vcsAddFiles Add the selected files or folders
vcsBlameOnGitHub Blame view for this file on Github
vcsCleanup Recursively clean up the working copy (removing locks, etc)
vcsCommit Commit pending changes
vcsDiff Diff selected file(s)
vcsFileDiff Show differences for the file
vcsFileLog Show log of changes to the file
vcsFileRevert Revert changes to the file
vcsIgnore Ignore the selected files or folders
vcsOpen Open selected file(s)
vcsPull Pull Branches
vcsPullRebase Pull with Rebase
vcsPush Push Branch
vcsRefresh Refresh listing
vcsRemoveFiles Delete the selected files or folders
vcsResolve Resolve conflicts in the selected files or folders
vcsRevert Revert selected changes
vcsShowHistory View history of previous commits
vcsViewOnGitHub View this file on Github
versionControlHelp Help on using version control with RStudio
versionControlOptions Configure version control options
versionControlProjectSetup Setup version control for the current project
versionControlShowRsaKey Show RSA public key
viewAllPrefs View All Prefs
viewerBack Go back
viewerClear Remove current viewer item
viewerClearAll Clear all viewer items
viewerCopyToClipboard Copy to the system clipboard
viewerForward Go forward
viewerPopout Show in new window
viewerRefresh Refresh viewer
viewerSaveAllAndRefresh Save source files and refresh viewer
viewerSaveAsImage Save as an image file
viewerSaveAsWebPage Save as a standalone web page
viewerStop Stop application
viewerZoom View a larger version in a new window
wordCount Count words in selection or document
zoomActualSize Actual Size
zoomIn Zoom In
zoomOut Zoom Out
zoomPlot View a larger version of the plot in a new window